you are here:
Welcome, Guest
Username Password: Remember me

Losing power under load
(1 viewing) (1) Guest
  • Page:
  • 1

TOPIC: Losing power under load

Losing power under load 6 years, 2 months ago #3807

Hi all

I just picked up a brand new 2013 DRZ400e from the dealer yesterday morning, ready to be run in.

When riding on the road and coming out of corners or going up small hills or trying to get to 100km/h on the highway, it misses / runs out of power and slows right down with the motor jerking on and off until I put it back a gear.

It also won't go faster than about 70km/h on easy flat roads and highways without losing power and jerking. My old 250 was quicker than this.

Any ideas what it could be?

Cheers

Re: Losing power under load 6 years, 2 months ago #3810

  • drztroy
  • OFFLINE
  • Gold Boarder
  • Posts: 294
I wouldn't worry about it. if you only picked it up yesterday, take it straight back to them and tell them the pre-delivery blokes didn't do there bloody job.
don't go playin with it or you might void the warranty, there has been a few stories on this forum about Suzuki dealers not doing what there ment to do..
take it back ASAP

Re: Losing power under load 6 years, 2 months ago #3812

  • xrman
  • OFFLINE
  • Gold Boarder
  • Posts: 182
It sounds as if the restrictors are still in place.

It is either not getting enough fuel or the exhaust is blocked.

Take it back to the dealer and ask that he fixes it or supplies you with another bike!

Mine came de-restricted from the dealer, but I think they have air box restrictors, a carbie screw restrictor, exahust restrictors to pass ADR tests.
  • Page:
  • 1
Time to create page: 0.13 seconds