you are here:

Private Messages

You are not logged in.

Hot Topics

More Topics »

Login form



Welcome, Guest
Username Password: Remember me

DRZ400E '05 runs on when throttle shut (not cable)
(1 viewing) (1) Guest
Share your modifications both the ones that worked and ones not worth doing.
  • Page:
  • 1

TOPIC: DRZ400E '05 runs on when throttle shut (not cable)

DRZ400E '05 runs on when throttle shut (not cable) 8 years, 3 months ago #2646

  • thehalk
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
Hello

Anyone have any ideas why my 2005 400E runs on when the throttle is shut? The cable/shaft are not stuck as the pulley hits the idle screw when the twist grip is closed. The engine continues to rev at about 1200rpm down to idle over a couple of seconds. It's annoying and not what you want when you decide you want to shut the throttle.

I guess that it's pilot related and will involve a strip, clean and rebuild but am just hoping that someone has come across it before and can point me in roughly the right direction. Had the diaphragm plate off this evening and there doesn't appear to be any damage there. Had a reasonable look at the air box and manifold joiners for cracks/splits but didn't see anything.

Thanks in advance.

Re: DRZ400E '05 runs on when throttle shut (not cable) 8 years, 2 months ago #2766

  • jerrygee
  • OFFLINE
  • Fresh Boarder
  • Posts: 4
mate sounds like a air leak.. check the manifold rubber from motor to carby or make sure the vacum line is not split.. the slightest split will cause it to do this..

Re: DRZ400E '05 runs on when throttle shut (not cable) 7 years, 2 months ago #3698

  • Jordo
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
Hey mate was just reading post mine was the same definitely air leak mine was top plate on carbie few screws and you will probably see where the air leak is (black) just use a gasket sealant and put cover back on
  • Page:
  • 1
Time to create page: 0.16 seconds